EC-CUBE情報

2.12対応のプラグインは2.13で動く可動か?

EC-CUBEのバージョンをあげたいけれど、使っているプラグインが2.13系にない場合どうするか。。

実際のところ2.12系と2.13系は構造的に近いので(一部明らかな異なりもありますが)、その使うプラグインが明らかに異なるPHPで動いている箇所でない場合は動くことも多いです。インストール自体は管理画面から行うことも問題ありません。

また、実際インストールしたけど動きがおかしくなることもあるので、その場合は使うのを諦めるか、プラグインのエラーの箇所を直接修正することで動く場合もあります。

この辺りはそのプラグインがどうしても使いたいのであればコストをかけてでも調整するメリットはありますが、なくても運営に支障なければ2.13対応のプラグインのみで構成するのが最もベストかもしれません。